Expand description
CMS identifiers used by the protocol’s schema and attribute rules.
Constants§
- ALGORITHM_
PROTECTION - Signed algorithm protection attribute (RFC6211 §2).
- ARCHIVE_
TIMESTAMP_ V3 - Unsigned
archive-time-stamp-v3,0.4.0.1733.2.4(EN 319 122-1 §5.5.3). - ATS_
HASH_ INDEX_ V3 - Unsigned
ats-hash-index-v3,0.4.0.19122.1.5(EN 319 122-1 §5.5.2). - CLAIMED_
SAML_ ASSERTION claimed-SAML-assertion,0.4.0.19122.1.2, carried only insidesigner-attributes-v2(EN 319 122-1 §5.2.6.2).- COMMITMENT_
TYPE_ INDICATION - Signed
commitment-type-indication(EN 319 122-1 §5.2.3). - CONTENT_
HINTS - Signed ESS content-hints (RFC2634 §2.9; EN 319 122-1 §5.2.4.1).
- CONTENT_
IDENTIFIER - Signed ESS content-identifier (RFC2634 §2.7; EN 319 122-1 §5.2.12).
- CONTENT_
REFERENCE - Signed ESS content-reference (RFC2634 §2.11; EN 319 122-1 §5.2.11).
- CONTENT_
TIMESTAMP - Signed
content-time-stamp(EN 319 122-1 §5.2.8). - CONTENT_
TYPE - Signed content-type attribute (RFC5652 §11.1).
- COUNTERSIGNATURE
- Unsigned countersignature attribute (RFC5652 §11.4).
- DATA
- Arbitrary octets,
id-data(RFC5652 §4). - MESSAGE_
DIGEST - Signed message-digest attribute (RFC5652 §11.2).
- MIME_
TYPE - Signed
mime-type,0.4.0.1733.2.1(EN 319 122-1 §5.2.4.2). - OCSP_
RESPONSE - Whole OCSP response in CMS
OtherRevocationInfoFormat(RFC5940 §3). - SHA1
- SHA-1 identifies the ESS V1 compatibility requirement (RFC5035 §2), not a cryptographic backend or a policy permission to accept that hash.
- SHA256
- Exact ASN.1 SHA-256 default identity in
ESSCertIDv2(RFC5035 §4). - SIGNATURE_
POLICY_ IDENTIFIER - Signed
signature-policy-identifier(EN 319 122-1 §5.2.9.1). - SIGNATURE_
POLICY_ STORE - Unsigned
signature-policy-store,0.4.0.19122.1.3(EN 319 122-1 §5.2.10). - SIGNATURE_
TIMESTAMP - Unsigned
signature-time-stamp(EN 319 122-1 §5.3). - SIGNED_
DATA - CMS
SignedData(RFC5652 §5). - SIGNER_
ATTRIBUTES_ V2 - Signed
signer-attributes-v2,0.4.0.19122.1.1(EN 319 122-1 §5.2.6.1). - SIGNER_
LOCATION - Signed
signer-location(EN 319 122-1 §5.2.5). - SIGNING_
CERTIFICATE - ESS signing-certificate V1 (RFC5035 §5).
- SIGNING_
CERTIFICATE_ V2 - ESS signing-certificate V2 (RFC5035 §3).
- SIGNING_
TIME - Signed signing-time attribute (RFC5652 §11.3).
- TST_
INFO - Encapsulated timestamp information,
id-ct-TSTInfo(RFC3161 §2.4.2).