puppetfile 0.2.2

Puppetfile parser
docs.rs failed to build puppetfile-0.2.2
Please check the build logs for more information.
See Builds for ideas on how to fix a failed build, or Metadata for how to configure docs.rs builds.
If you believe this is docs.rs' fault, open an issue.
Visit the last successful build: puppetfile-0.2.0

rust-puppetfile

Build Status

Small Puppetfile Parser

Usage

let puppetfile = Puppetfile::parse(r##"forge "https://forge.puppetlabs.com"

mod 'mayflower/php', '1.0.1'
        "##);

See examples for another simple example or src/bin/pumuckl.rs as real use case

Documentation

At rust-ci

Pumuckl

Pumuckl checks a Puppetfile for newer versions of modules on the puppet forge Simply run it with:

cargo build
./target/pumuckl path to Puppetfile