openai 0.4.1

OpenAI client for Rust
docs.rs failed to build openai-0.4.1
Please check the build logs for more information.
See Builds for ideas on how to fix a failed build, or Metadata for how to configure docs.rs builds.
If you believe this is docs.rs' fault, open an issue.
Visit the last successful build: openai-0.4.0

rust-openai

Bindings to OpenAI Gym/Universe for Rust language

Edge Detection

Installation

Docker and Rust are required for this client to work

Linux

Docker

Official Ubuntu 16.04

Rust
curl https://sh.rustup.rs -sSf | sh

OSX

Docker

Docker

Rust
curl https://sh.rustup.rs -sSf | sh
Other dependencies
xcode-select --install
brew install openssl

You may also need to point to your systems openssl installation:

export OPENSSL_INCLUDE_DIR=/usr/local/opt/openssl/include
export DEP_OPENSSL_INCLUDE=/usr/local/opt/openssl/include
source ~/.bashrc
Running a game

./target/release/random --game flashgames.WreckRoad-v0

Available game tags can be found at [https://universe.openai.com/envs](OpenAI site).