gdkwayland 0.15.5

Rust bindings of the GDK-Wayland 3 library
docs.rs failed to build gdkwayland-0.15.5
Please check the build logs for more information.
See Builds for ideas on how to fix a failed build, or Metadata for how to configure docs.rs builds.
If you believe this is docs.rs' fault, open an issue.
Visit the last successful build: gdkwayland-0.0.0

Rust GDK3-Wayland bindings

Project site is here.

Rust bindings and wrappers for GDK3-Wayland, part of gtk3-rs.

GDK3-Wayland 3.18 is the lowest supported version for the underlying library.

Minimum supported Rust version

Currently, the minimum supported Rust version is 1.56.0.

Documentation

Using

We recommend using crates from crates.io, as demonstrated here.

If you want to track the bleeding edge, use the git dependency instead:

[dependencies]
gdkwayland = { git = "https://github.com/gtk-rs/gtk3-rs.git", package = "gdkwayland" }

Avoid mixing versioned and git crates like this:

# This will not compile
[dependencies]
gdkwayland = "0.15"
gdkwayland = { git = "https://github.com/gtk-rs/gtk3-rs.git", package = "gdkwayland" }

See Also

License

gdk_waylang is available under the MIT License, please refer to it.