crossbeam-deque 0.7.2

Concurrent work-stealing deque

Crossbeam Deque

Build Status License Cargo Documentation Rust 1.28+ chat

This crate provides work-stealing deques, which are primarily intended for building task schedulers.

Usage

Add this to your Cargo.toml:

[dependencies]
crossbeam-deque = "0.7"

Next, add this to your crate:

extern crate crossbeam_deque;

Compatibility

The minimum supported Rust version is 1.28. Any change to this is considered a breaking change.

License

Licensed under either of

at your option.

Contribution

Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.