pub struct ProcessActivity {Show 15 fields
pub class_uid: u16,
pub category_uid: u8,
pub type_uid: u32,
pub activity_id: u8,
pub activity_name: Option<String>,
pub time: i64,
pub severity_id: u8,
pub severity: Option<String>,
pub status_id: u8,
pub status: Option<String>,
pub message: Option<String>,
pub metadata: Metadata,
pub process: OcsfProcess,
pub actor: Option<Actor>,
pub unmapped: Option<Value>,
}Expand description
OCSF Process Activity event (class_uid = 1007).
Fields§
§class_uid: u16Always 1007.
category_uid: u8Always 1 (System Activity).
type_uid: u32class_uid * 100 + activity_id.
activity_id: u8Activity ID.
activity_name: Option<String>Human-readable activity name.
time: i64Event time as epoch milliseconds.
severity_id: u8Severity ID (0-6, 99).
severity: Option<String>Human-readable severity label.
status_id: u8Status ID (0=Unknown, 1=Success, 2=Failure).
status: Option<String>Human-readable status label.
message: Option<String>Human-readable event message.
metadata: MetadataMetadata (required).
process: OcsfProcessThe process (required).
actor: Option<Actor>Actor who initiated the process activity.
unmapped: Option<Value>Vendor-specific unmapped data.
Implementations§
Source§impl ProcessActivity
impl ProcessActivity
Sourcepub fn new(
activity: ProcessActivityType,
time: i64,
severity_id: u8,
status_id: u8,
metadata: Metadata,
process: OcsfProcess,
) -> Self
pub fn new( activity: ProcessActivityType, time: i64, severity_id: u8, status_id: u8, metadata: Metadata, process: OcsfProcess, ) -> Self
Create a new Process Activity event with required fields.
Sourcepub fn with_message(self, msg: impl Into<String>) -> Self
pub fn with_message(self, msg: impl Into<String>) -> Self
Set the event message.
Sourcepub fn with_actor(self, actor: Actor) -> Self
pub fn with_actor(self, actor: Actor) -> Self
Set the actor.
Sourcepub fn with_unmapped(self, unmapped: Value) -> Self
pub fn with_unmapped(self, unmapped: Value) -> Self
Set unmapped vendor data.
Trait Implementations§
Source§impl Clone for ProcessActivity
impl Clone for ProcessActivity
Source§fn clone(&self) -> ProcessActivity
fn clone(&self) -> ProcessActivity
Returns a duplicate of the value. Read more
1.0.0 · Source§fn clone_from(&mut self, source: &Self)
fn clone_from(&mut self, source: &Self)
Performs copy-assignment from
source. Read moreSource§impl Debug for ProcessActivity
impl Debug for ProcessActivity
Source§impl<'de> Deserialize<'de> for ProcessActivity
impl<'de> Deserialize<'de> for ProcessActivity
Source§fn deserialize<__D>(__deserializer: __D) -> Result<Self, __D::Error>where
__D: Deserializer<'de>,
fn deserialize<__D>(__deserializer: __D) -> Result<Self, __D::Error>where
__D: Deserializer<'de>,
Deserialize this value from the given Serde deserializer. Read more
Source§impl PartialEq for ProcessActivity
impl PartialEq for ProcessActivity
Source§impl Serialize for ProcessActivity
impl Serialize for ProcessActivity
impl StructuralPartialEq for ProcessActivity
Auto Trait Implementations§
impl Freeze for ProcessActivity
impl RefUnwindSafe for ProcessActivity
impl Send for ProcessActivity
impl Sync for ProcessActivity
impl Unpin for ProcessActivity
impl UnsafeUnpin for ProcessActivity
impl UnwindSafe for ProcessActivity
Blanket Implementations§
Source§impl<T> BorrowMut<T> for Twhere
T: ?Sized,
impl<T> BorrowMut<T> for Twhere
T: ?Sized,
Source§fn borrow_mut(&mut self) -> &mut T
fn borrow_mut(&mut self) -> &mut T
Mutably borrows from an owned value. Read more