Skip to main content

Module registry

Module registry 

Source
Expand description

IANA IPFIX registries

Constants and types mirroring the IANA IP Flow Information Export (IPFIX) Entities registries. The Information Element table INFORMATION_ELEMENTS is generated from the IANA registry (make registry-update) and validated against it by make specs-validate.

Modules§

type_records
Information Elements of an Information Element type record (RFC 5610 Section 3.9, Table 4). Validated against the RFC by make specs-validate.

Structs§

InformationElement
An IANA-registered Information Element

Enums§

DataType
IPFIX abstract data type - RFC 7012 Section 3.1
DataTypeSemantics
Data type semantics - RFC 7012 Section 3.2
Status
Registration status of an Information Element (RFC 7013 Section 5.2)

Constants§

INFORMATION_ELEMENTS
All IANA-assigned Information Elements, sorted by ElementID
IPFIX_VERSION
IPFIX Version Number (IANA “IPFIX Version Numbers” registry)
MIN_DATA_SET_ID
First Set ID reserved for Data Sets (IANA “IPFIX Set IDs” registry)
OPTIONS_TEMPLATE_SET_ID
Set ID of Options Template Sets (IANA “IPFIX Set IDs” registry)
REVERSE_INFORMATION_ELEMENT_PEN
Private Enterprise Number signifying “IPFIX Reverse Information Element” (RFC 5103 Section 6.1)
TEMPLATE_SET_ID
Set ID of Template Sets (IANA “IPFIX Set IDs” registry)

Functions§

lookup
Look up an IANA Information Element by identifier
lookup_by_name
Look up an IANA Information Element by name