Trait gridsim::TakeMoveDirection[][src]

pub trait TakeMoveDirection<Idx, Dir, Move> {
    unsafe fn take_move_direction(&self, _: Idx, _: Dir) -> Move;
}

Required Methods

This should be called exactly once for every index and direction.

This is marked unsafe to ensure people read the documentation due to the above requirement.

Implementors