Trait gridsim::TakeDiff[][src]

pub trait TakeDiff<Idx, Diff> {
    unsafe fn take_diff(&self, _: Idx) -> Diff;
}

Required Methods

This should be called exactly once for every index, making it unsafe.

This is marked unsafe to ensure people read the documentation due to the above requirement.

Implementors