wasmer-wasm-interface 4.2.8

WASM Interface definition and parser
Documentation
[package]
name = "wasmer-wasm-interface"
description = "WASM Interface definition and parser"
readme = "README.md"
authors.workspace = true
edition.workspace = true
homepage.workspace = true
license.workspace = true
repository.workspace = true
rust-version.workspace = true
version.workspace = true

[dependencies]
bincode = { version = "1", optional = true }
either = "1.5"
nom = "5"
serde = { version = "1", features = ["derive"] }
wasmparser = { workspace = true, optional = true }

[dev-dependencies]
wat = "1.0"

[features]
validation = ["wasmparser"]
binary_encode = ["bincode"]
default = ["validation"]

[package.metadata.docs.rs]
rustc-args = ["--cfg", "docsrs"]