sundials-sys 0.2.1

A -sys crate for the SUNDIALS suite of ODE solvers
docs.rs failed to build sundials-sys-0.2.1
Please check the build logs for more information.
See Builds for ideas on how to fix a failed build, or Metadata for how to configure docs.rs builds.
If you believe this is docs.rs' fault, open an issue.
Visit the last successful build: sundials-sys-0.2.3

sundials-sys

A barebones -sys crate around the SUNDIALS suite of ODE solvers. The system must have CMake (cmake dependency) and clang (bindgen dependency) already installed for compilation to succeed.

License

The license and copyright information for the SUNDIALS suite can be viewed here. At the time of writing, it is a BSD 3-Clause license. The code specific to this crate is also made available under the BSD 3-Clause license.

Versions

  • 0.2.0 -- Make compilation of sundials optional (allowing to link against the system library). Add static library option.
  • 0.1.1 -- removal of (S) libraries from default features, addition of pthreads support if requested
  • 0.1.0 -- initial -sys wrapper with minor tests