spectrum-analyzer 1.5.0

An easy to use and fast `no_std` library (with `alloc`) to get the frequency spectrum of a digital signal (e.g. audio) using FFT.
Documentation
{ pkgs ? import <nixpkgs> {} }:
  pkgs.mkShell rec {
    nativeBuildInputs = with pkgs; [
      pkg-config
      cargo-nextest
    ];

    buildInputs = with pkgs; [
      alsa-lib
      fontconfig
      libxkbcommon
      xorg.libXcursor
      xorg.libX11
    ];

  LD_LIBRARY_PATH = "${pkgs.lib.makeLibraryPath buildInputs}";
}