grpcio 0.4.2

The rust language implementation of gRPC, base on the gRPC c core library.
Documentation
# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
#
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
# to registry (e.g. crates.io) dependencies
#
# If you believe there's an error in this file please file an
# issue against the rust-lang/cargo repository. If you're
# editing this file be aware that the upstream Cargo.toml
# will likely look very different (and much more reasonable)

[package]
name = "grpcio"
version = "0.4.2"
authors = ["The TiKV Project Developers"]
autoexamples = false
description = "The rust language implementation of gRPC, base on the gRPC c core library."
homepage = "https://github.com/pingcap/grpc-rs"
documentation = "https://docs.rs/grpcio"
readme = "README.md"
keywords = ["grpc", "protobuf", "rpc", "tls", "http2"]
categories = ["asynchronous", "network-programming"]
license = "Apache-2.0"
repository = "https://github.com/pingcap/grpc-rs"
[package.metadata.docs.rs]
all-features = true
[profile.release]
debug = true

[[example]]
name = "route_guide_client"
path = "examples/route_guide/client.rs"

[[example]]
name = "route_guide_server"
path = "examples/route_guide/server.rs"

[[example]]
name = "greeter_client"
path = "examples/hello_world/client.rs"

[[example]]
name = "greeter_server"
path = "examples/hello_world/server.rs"
[dependencies.futures]
version = "^0.1.15"

[dependencies.grpcio-sys]
version = "0.4.2"

[dependencies.libc]
version = "0.2"

[dependencies.log]
version = "0.4"

[dependencies.protobuf]
version = "~2.0"
optional = true
[dev-dependencies.grpcio-proto]
version = "0.4.0"

[dev-dependencies.rand]
version = "0.4"

[dev-dependencies.serde]
version = "1.0"

[dev-dependencies.serde_derive]
version = "1.0"

[dev-dependencies.serde_json]
version = "1.0"

[dev-dependencies.slog]
version = "2.0"

[dev-dependencies.slog-async]
version = "2.1"

[dev-dependencies.slog-scope]
version = "4.0"

[dev-dependencies.slog-stdlog]
version = "3.0"

[dev-dependencies.slog-term]
version = "2.2"

[features]
default = ["protobuf-codec", "secure"]
openssl = ["secure", "grpcio-sys/openssl"]
protobuf-codec = ["protobuf"]
secure = ["grpcio-sys/secure"]
[badges.appveyor]
repository = "busyjay/grpc-rs"

[badges.travis-ci]
repository = "pingcap/grpc-rs"