[][src]Trait gridsim::TakeDiff

pub trait TakeDiff<Idx, Diff> {
    unsafe fn take_diff(&self, ix: Idx) -> Diff;
}

Required methods

unsafe fn take_diff(&self, ix: Idx) -> Diff

This should be called exactly once for every index, making it unsafe.

This is marked unsafe to ensure people read the documentation due to the above requirement.

Loading content...

Implementors

impl<'a, S, D> TakeDiff<usize, D> for SquareGrid<'a, S> where
    S: Sim<'a, Diff = D>, 
[src]

Loading content...