exonum-explorer 1.0.0-rc.2

Blockchain explorer utils for the Exonum framework

Blockchain Explorer Utils for Exonum

Travis Build Status License: Apache-2.0 rust 1.41.0+ required

exonum-explorer provides explorer API for the Exonum blockchain framework. For example, it allows to request transactions from a block together with the execution statuses, iterate over blocks, etc.

This crate is distinct from the explorer service crate. While this crate provides Rust language APIs for retrieving info from the blockchain, the explorer service translates these APIs into REST and WebSocket endpoints. Correspondingly, this crate is primarily useful for Rust-language client apps. Another use case is testing; the testkit relies on types in this crate and re-exports it as the explorer module.

Consult the crate docs and examples for more details about the service API.

Usage

Include exonum-explorer as a dependency in your Cargo.toml:

[dependencies]
exonum = "1.0.0-rc.2"
exonum-explorer = "1.0.0-rc.2"

License

exonum-explorer is licensed under the Apache License (Version 2.0). See LICENSE for details.