sccache 0.2.4

Sccache is a ccache-like tool. It is used as a compiler wrapper and avoids compilation when possible, storing a cache in a remote storage using the S3 API.
# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
#
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
# to registry (e.g. crates.io) dependencies
#
# If you believe there's an error in this file please file an
# issue against the rust-lang/cargo repository. If you're
# editing this file be aware that the upstream Cargo.toml
# will likely look very different (and much more reasonable)

[package]
name = "sccache"
version = "0.2.4"
authors = ["Ted Mielczarek <ted@mielczarek.org>", "Alex Crichton <alex@alexcrichton.com>"]
description = "Sccache is a ccache-like tool. It is used as a compiler wrapper and avoids compilation when possible, storing a cache in a remote storage using the S3 API."
readme = "README.md"
keywords = ["ccache"]
categories = ["command-line-utilities", "development-tools::build-utils"]
license = "Apache-2.0"
repository = "https://github.com/mozilla/sccache/"
[profile.release]
debug = true
[dependencies.app_dirs]
version = "1.1.1"

[dependencies.base64]
version = "0.5.2"

[dependencies.bincode]
version = "0.8"

[dependencies.byteorder]
version = "1.0"

[dependencies.chrono]
version = "0.3"
optional = true

[dependencies.clap]
version = "2.23.0"

[dependencies.env_logger]
version = "0.4"

[dependencies.error-chain]
version = "0.11"
default-features = false

[dependencies.fern]
version = "0.3.5"

[dependencies.filetime]
version = "0.1"

[dependencies.futures]
version = "0.1.11"

[dependencies.futures-cpupool]
version = "0.1"

[dependencies.hyper]
version = "0.11"
optional = true

[dependencies.hyper-tls]
version = "0.1"
optional = true

[dependencies.jsonwebtoken]
version = "2.0"
optional = true

[dependencies.libc]
version = "0.2.10"

[dependencies.local-encoding]
version = "0.2.0"

[dependencies.log]
version = "0.3.6"

[dependencies.lru-disk-cache]
version = "0.1.0"

[dependencies.native-tls]
version = "0.1"

[dependencies.number_prefix]
version = "0.2.5"

[dependencies.openssl]
version = "0.9"
optional = true

[dependencies.redis]
version = "0.8.0"
optional = true

[dependencies.regex]
version = "0.2"

[dependencies.retry]
version = "0.4.0"

[dependencies.ring]
version = "0.9.0"

[dependencies.rust-crypto]
version = "0.2.36"
optional = true

[dependencies.serde]
version = "1.0"

[dependencies.serde_derive]
version = "1.0"

[dependencies.serde_json]
version = "1.0"

[dependencies.tempdir]
version = "0.3.4"

[dependencies.tempfile]
version = "2.1.5"

[dependencies.time]
version = "0.1.35"

[dependencies.tokio-core]
version = "0.1.6"

[dependencies.tokio-io]
version = "0.1"

[dependencies.tokio-process]
version = "0.1"

[dependencies.tokio-proto]
version = "0.1"

[dependencies.tokio-serde-bincode]
version = "0.1"

[dependencies.tokio-service]
version = "0.1"

[dependencies.tokio-tls]
version = "0.1"

[dependencies.url]
version = "1.0"
optional = true

[dependencies.uuid]
version = "0.5"
features = ["v4"]

[dependencies.which]
version = "1.0"

[dependencies.zip]
version = "=0.2.3"
default-features = false
[dev-dependencies.assert_cli]
version = "0.5"

[dev-dependencies.gcc]
version = "0.3"

[dev-dependencies.itertools]
version = "0.6"

[features]
all = ["redis", "s3"]
default = ["s3"]
gcs = ["chrono", "hyper", "hyper-tls", "jsonwebtoken", "openssl", "url"]
s3 = ["chrono", "hyper", "hyper-tls", "rust-crypto", "simple-s3"]
simple-s3 = []
unstable = []
[target."cfg(unix)".dependencies.daemonize]
version = "0.2.3"

[target."cfg(unix)".dependencies.tokio-uds]
version = "0.1"
[target."cfg(windows)".dependencies.kernel32-sys]
version = "0.2.2"

[target."cfg(windows)".dependencies.mio-named-pipes]
version = "0.1"

[target."cfg(windows)".dependencies.winapi]
version = "0.2"
[badges.appveyor]
repository = "mozilla/sccache"

[badges.travis-ci]
repository = "mozilla/sccache"