rusoto_core 0.29.0

AWS SDK for Rust - Core

Rusoto Core

Rusoto Core contains core functionality shared across AWS services, such as region definitions, credentials and common request-sending and parsing logic.


You may be looking for:

Requirements

Rust 1.15.0 or later is required.

On Linux, OpenSSL is required.

Installation

Rusoto Core is available on crates.io. To use Rusoto in your Rust program built with Cargo, add it as a dependency in your Cargo.toml:

[dependencies]
rusoto_core = "0.28.0"

Usage

Rusoto Core should be paired with Rusoto services to able to be able to work with them. Consult the documentation for those services to see how it should be used with them.

Consult the rustdoc documentation for full details by running cargo doc or visiting the online documentation for the latest crates.io release.

Credentials

For more information on Rusoto's use of AWS credentials such as priority and refreshing, see AWS Credentials.

Semantic versioning

Rusoto complies with semantic versioning 2.0.0. Until reaching 1.0.0 the API is to be considered unstable. See Cargo.toml or rusoto on crates.io for current version.

Releases

Information on release schedules and procedures are in RELEASING.

Contributing

See CONTRIBUTING.

Supported OSs and Rust versions

Linux, OSX and Windows are supported and tested via TravisCI and Appveyor.

Rust stable is supported. Older versions of Rust are supported and tested via TravisCI. The minimum Rust version is incremented when it becomes inconvenient to support older versions. The current minimum version of Rust supported can be found in .travis.yml. If a version number is not specified in the rust section, only the named versions listed are supported. This should be stable, beta and nightly.

License

Rusoto is distributed under the terms of the MIT license.

See LICENSE for details.