[][src]Trait gridsim::TakeMoveDirection

pub trait TakeMoveDirection<Idx, Dir, Move> {
    unsafe fn take_move_direction(&self, ix: Idx, dir: Dir) -> Move;
}

Required methods

unsafe fn take_move_direction(&self, ix: Idx, dir: Dir) -> Move

This should be called exactly once for every index and direction.

This is marked unsafe to ensure people read the documentation due to the above requirement.

Loading content...

Implementors

impl<'a, S, M> TakeMoveDirection<usize, MooreDirection, M> for SquareGrid<'a, S> where
    S: Sim<'a, Move = M, MoveNeighbors = MooreNeighbors<M>>, 
[src]

impl<'a, S, M> TakeMoveDirection<usize, NeumannDirection, M> for SquareGrid<'a, S> where
    S: Sim<'a, Move = M, MoveNeighbors = NeumannNeighbors<M>>, 
[src]

Loading content...