alpm 0.4.0

Pacman interface.

Crate alpm [] [src]

Alpm is your interface to pacman from rust.

It only works on an Arch Linux installation.

Example

To query the current version of pacman

let pacman = alpm::Alpm::new().unwrap();

assert_eq!("5.0.1-4".to_string(), pacman.query_package_version("pacman").unwrap());Run

Structs

Alpm

Constants

PACMAN_CONF
PACMAN_DEFAULT_DBPATH